Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mponomarenko

Pages: [1]
1
when DefaultJListTableRenderer seems to completly ignore bounds set on JList component.
Particularly we have JList with a lot of items, and it has bounds set ~3 times smaller than item count so that scrollbar of JList itself should appear - instead DefaultJListTableRenderer renders table that does not take size into account and as a result half of items are not visible.


2
Community Technical Support / Re: inflation conversion bug?
« on: July 30, 2009, 05:25:57 PM »
the fix does prevent zindex of frame from growing when there is only one frame, but, it still rerenders whole page since code expects zIdex to be greater  by one: if (updateContext.zIndex != currentZOrder + 1)

Another problem is when you switch focus between 2 internal frames few times, zIndex grows and never gets lower, which means that all subsequent request will invalidate frame, even if one frame is closed.

3
Community Technical Support / Re: IE6 menu styles in AjaxSwing 2.5.0
« on: July 29, 2009, 10:48:07 PM »
right. IE6 prefers first CSS rule that sets text size for A, and ignores one in "menu" that sets it to 12px. Even if I set as important.

4
Community Technical Support / Re: IE6 menu styles in AjaxSwing 2.5.0
« on: July 29, 2009, 06:24:09 PM »
that is because I have intentionnaly removed them from there. Or menu would "jump"

5
Community Technical Support / Re: inflation conversion bug?
« on: July 24, 2009, 07:46:19 PM »
firther investigation has shown that one pixel movement is not the cause (it is ignored) - the actual cause is change of zIndex.
according to debugging follwing happens when I click window:
 1. drag starts. removes shadow.
 2. drag ends. recreates shadow. it shifts frame position 1 zIndex upper
 3. onmousedown happens, does not find form at required zIndex position and moves it 2 zindex upper. as results zidex grows on every click.

happens always.

6
Community Technical Support / inflation conversion bug?
« on: July 24, 2009, 05:53:32 PM »
We have a strange problem, that somehow only noticable in IE7 - when dropdown field change causes page submit, whole frame gets re-rendered. It turned out that this is a result of one pixel movement of the frame:
Code: [Select]

2009/07/25 00:42:10:640 : AWT-EventQueue-1 : [com.creamtec.ajaxswing.gui.html.DefaultJComponentUpdater] updateComponent for window, value = 298,277,423,114,101,false,true
2009/07/25 00:42:10:640 : AWT-EventQueue-1 : [com.creamtec.ajaxswing.gui.WindowUpdateContext] Window bounds are: 270,263,384,89, old bounds = java.awt.Rectangle[x=271,y=264,width=385,height=90]


It seems to me that this is due to inflate.height inflate.width conversion - it does not convert back to exact same spot.

7
Community Technical Support / IE6 menu styles in AjaxSwing 2.5.0
« on: July 23, 2009, 05:46:54 PM »
IE6 menu text is 11px, and ":hover" it is 12px which causes menu to change its size. setting "!important" did not help anyhwere.
The best I could do is remove explicit 12px setting from everything related to menu except ".wcPulldownMenu a, a.menuButton" line which results in IE6 having 11px allways, and all other browsers having 12px.

I can attach my styles_commons.css (Blue theme). Is there any way to have 12px except setting in in general "a" secion on top?

8
Community Technical Support / IE8 Compatibility mode
« on: July 23, 2009, 04:55:29 PM »
I have spent some time debugging nonexistent problem, and want to share:
 IE8 by default shows all sites on intranet in IE7 document mode, and in that mode it sometimes exposes shifting of content (invisible wcPulldownMenu below the pane take space, and shift contents upper), so be sure to disable compatibility mode in IE8 before testing, or, if your application will run on intranet - just make sure you test in same mode as your users will use it.

P.S. this problem with shifting does not exist in real IE7

9
Community Technical Support / way to access http session?
« on: May 19, 2009, 08:30:58 AM »
Is there a clean way to access HttpSession from swing application?

What we actually need is a value that is user-dependant value that is accessible from application and from HttpFilter, and we think JSESSIONID fits but we cant access it from swing.

10
Community Technical Support / ComponentUtils.getHtmlAttributes support
« on: September 09, 2008, 03:20:53 AM »
In AjaxSwing 2.1.2 you have introduced ComponentUtils.getHtmlAttributes which is really usefull for setting tab index and such. Now , I was trying to use it for setting "accesskey" attribute, and, fount out that HtmlAttributes are ignored by AjaxSwing for image buttons (that get rendered as "A" tag).

Please, add support for ComponentUtils.getHtmlAttributes to at least all tags that support "accesskey". (to save you some time, here is a list: http://www.w3.org/TR/html401/interact/forms.html#h-17.11.2 )

11
Community Technical Support / AjaxSwing 2.2.0 testing results
« on: September 05, 2008, 03:05:23 PM »
I was testing the upgrade of our application from AjaxSwing 2.1 to AjaxSwing 2.2.0 and I can say that it is very good.
  • it is MUCH faster then the previous version
  • it works with Opera, Firefox 3, Safari and Google Chrome
  • since I can use this browsers, which are faster than IE6/7 and FF2 - it feels even faster than Swing within specific parts of the app

  • ther are hovever some glitches:
  • in Opera I have to use "mask as Firefox" feature in order to use menu
  • in other browsers(webkit ones) I can't use menu - it just ignores my clicks (seems to be related to preventing duplicate events in FF and IE)
  • webkit browers start to ignore my activity if I try to open a screen with WYSIWYG editor
  • Opera opens our custom WYSIWYG editor, and it does work, but spell check does not see any misspellings at all

  • generally - application I am working on is usable in just about any browser in the wild (except lynx), and works great in FF3.

    12
    Community Technical Support / Re: Problem statring with debugger
    « on: August 21, 2008, 11:48:41 AM »
    Belive it or not, but setting inProcess=false, starting, setting to inProcess=true, cleaning all caches, and starting again worked!

    13
    Community Technical Support / Problem statring with debugger
    « on: August 21, 2008, 11:41:41 AM »
    I am starting AjaxSwing with debugger, which is configured in setEnv.cmd.

    -Xdebug -Xrunjdwp:server=y,transport=dt_socket,address=4142,suspend=n  -Dgems.home="%GEMS_HOME%"
    set JAVA_OPTS=%JAVA_OPTS%

    It used to work, but suddenly it sopped working and now the application wont start:

    com.creamtec.ajaxswing.core.AjaxSwingException: Timed out while waiting for a new JVM process. Possible reasons are:<ul>
    <li> Application classes are not not found<li> JAVA_HOME environment variable is not set correctly (see AjaxSwing/bin/setEnv.bat)<li> AJAXSWING_HOME environment variable is not set correctly (see AjaxSwing/bin/setEnv.bat)<li> System configuration prevents AjaxSwing Router from launching agent process<li> The timeout value for router.agentWaitTimeout in default.properties is too low</ul>Check AjaxSwing log files for application errors.<br>Double check that you have made your classes available to AjaxSwing and that you can run AjaxSwing/bin/clientagent[.bat] with correct parameters manually
            at com.creamtec.ajaxswing.core.JVMFactory.waitForJVM(JVMFactory.java:189)
            at com.creamtec.ajaxswing.core.JVMFactory.launchJVM(JVMFactory.java:118)
            at com.creamtec.ajaxswing.core.JVMFactory.getAvailableJVM(JVMFactory.java:57)
            at com.creamtec.ajaxswing.core.ClientAgentFactory.createNewAgent(ClientAgentFactory.java:204)
            at com.creamtec.ajaxswing.core.ClientAgentFactory$1.run(ClientAgentFactory.java:131)
    2008/08/21 18:41:25:500 : Thread-3 : [com.creamtec.ajaxswing.core.ClientAgentFactory] createNewAgent, creating a new cli
    ent attempt 0

    I am running in "router.inProcess=true" mode, and expect to have one single JVM. Seems that AjaxSwing anyhow starts new JVM, that faild to load on specified port.

    14
    thank you, it worked like a charm.
    I have also found that in http://www.creamtec.com/products/ajaxswing/doc/setup.html#UnixInst "Configuring Graphics Environment" section

    15
    I am trying to execute AjaxSwing 2.1.2 under linux, and it fails to initialize deployed application (I have fixed my property file to use ":" instead of windows's ";" for delimiter)

    here is a snap of stacktrace from ajaxswing.log:
    java.lang.ClassCastException: com.creamtec.ajaxswing.gui.AjaxSwingGraphicsEnvironment
            at sun.awt.motif.MFontConfiguration.getFileNameFromComponentFontName(MFontConfiguration.java:293)
            at sun.awt.FontConfiguration.get2DCompositeFontInfo(FontConfiguration.java:957)
            at sun.java2d.SunGraphicsEnvironment.initCompositeFonts(SunGraphicsEnvironment.java:800)
            at sun.java2d.SunGraphicsEnvironment.access$400(SunGraphicsEnvironment.java:58)
            at sun.java2d.SunGraphicsEnvironment$1.run(SunGraphicsEnvironment.java:290)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.java2d.SunGraphicsEnvironment.<init>(SunGraphicsEnvironment.java:94)
            at com.creamtec.ajaxswing.gui.AjaxSwingGraphicsEnvironment.<init>(AjaxSwingGraphicsEnvironment.java:23)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
            at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
            at java.lang.Class.newInstance0(Class.java:350)
            at java.lang.Class.newInstance(Class.java:303)
            at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:68)
            at com.creamtec.ajaxswing.gui.AjaxSwingToolkit.<init>(AjaxSwingToolkit.java:150)


    java command according to "ps ax" has following arguments:
    /usr/lib/jvm/jdk1.5.0_15//bin/java -noverify -Xms64m -Xmx512m -XX:PermSize=256m -XX:MaxPermSize=256m -Xbootclasspath/p:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/lib/boot/asboot.jar -mx312m -Dajaxswing.home=/home/maniac/work/GEMSServer/AjaxSwing2.1.2 -Djava.awt.fonts=/home/maniac/work/GEMSServer/AjaxSwing2.1.2/lib/fonts:/usr/lib/jvm/jdk1.5.0_15//jre/lib/fonts -Dgems.home=/home/maniac/work/GEMSServer/GemsLive -Djava.endorsed.dirs=/home/maniac/work/GEMSServer/AjaxSwing2.1.2/tomcat/common/endorsed -classpath /usr/lib/jvm/jdk1.5.0_15//lib/tools.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/tomcat/common/lib/servlet-api.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/wcapps/lib/classes:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/lib/ajaxswing.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/lib/commons-fileupload-1.0.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/lib/freemarker.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/lib/jsonrpc-1.0.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/lib/*.zip:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/wcapps/lib/SwingSet2.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/wcapps/lib/*.zip::/home/maniac/work/GEMSServer/AjaxSwing2.1.2/tomcat/bin/bootstrap.jar:/home/maniac/work/GEMSServer/AjaxSwing2.1.2/tomcat/bin/commons-logging-api.jar -Dcatalina.base=/home/maniac/work/GEMSServer/AjaxSwing2.1.2/tomcat

    could you please help me?

    Pages: [1]