Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jlessner

Pages: [1] 2 3 4
1
Commercial Technical Support / Re: NumberFormatException with __RequestId
« on: January 04, 2012, 11:56:57 AM »
We definitely don't set a component name to "__RequestId" or something like that. Unfortunatly I wasn't able yet to reproduce the problem by myself, so I can't tell if refreshing helps. I will ask our first-level-support for more information.

I attached a log file with multiple occurences of the problem. Ingore the lines with "Tomcat 1/2 bla bla bla", this was added manually for a better overview. As you can see, the 5 trailing values are always the same, only the first 2 vary. Have you got an idea what these numbers may represent? The middle 4 numbers look a little like absolute positioning specifications.

2
Commercial Technical Support / NumberFormatException with __RequestId
« on: January 04, 2012, 09:47:16 AM »
Hello everybody
We noticed some exceptions in AjaxSwing being concerned with toolkit's internal HTTP request ID. If you have a look on the attached log file, there occured a NumberFormatException when parsing a Long value. From the stack trace and the parsed value it seems that AjaxSwing tried to parse the __RequestId parameter as a number which in this error case has multiple commas in it and therefore can't be parsed.  The exception occurs from time to time causing the user to be kicked out of the application, and we have no idea how to solve that.

Do you have any idea what may cause the problem?

Regards,
Jan Lessner

3
OK, I just checked your proposed quick fix and it works for our application. So I will stick to that one and wait for the release update.
Thanks for quick help!  :)

4
Hello Dev Team
We encountered an unexpected behaviour which costs a lot of time in our application. When we display a table and the user selects a single line in that table, AjaxSwing generates an HTTP request which seems to send the complete table content again. This happens with every single click on a row. There is no listener added to the table, neither a mouse listener nor a list selection listener, and the table is completely read-only. So in general there is no need to communicate with the server at all when selecting a line.

Any idea why this happens? Is there a way around that?

We are working with AjaxSwing 3.2.3. The behaviour occurs with every browser (IE, Chrome, Firefox).

I attached a minimal code sample.

5
I'm still looking forward for a solution for this problem :-[
We have a commercial customer to satisfy...

6
That doesn't seem to work. When I put that line into my application's AjaxSwing property file, I don't longer receive any events at all. It looks as if the line causes the very opposite of what it is intended for. However, I don't have a problem *receiving* the double-click events. It's just a problem finding out the correct selection index.

By the way: everything works perfect for tables - the whole thing happens for lists only.

Did you check out the attached example? Do you get it to work with the additional line in the property file you mentioned?

Regards,
Jan

7
I added a mouse listener to a JList to detact double-click events on items of the list. But when I ask for the currently selected item, I get the wrong selection index from JList.getSelectedIndex oder JList.getSelectionModel.get...SelectionIndex(). I attached a minimal example which works well on Swing.

Any idea what may have gone wrong here?

We are using AjaxSwing 3.1.0 RC1.

Regards,
Jan

8
OK, we solved the problem by our style sheet. It seems that the priorities have changed in 3.1.0. We override .button style but not .btn-no-border style which caused AjaxSwing's default style to be applied for borderless buttons in older releases. With 3.1.0 it seems to be different, but we could solve the problem by copying the default .btn-no-border style to our custome style sheet.

Thanks for your help,
Jan

9
Hier it comes.

10
OK - it works fine k´now with AjaxSwing 3.1.0 RC. Thanks a lot for that one.
However, with the new release we just discovered a display problem. See http://creamtec.com/forums/index.php?topic=433.0.

Regards,
Jan

11
Commercial Technical Support / Button borders not completly invisible
« on: July 06, 2010, 05:21:20 AM »
I just checked AjaxSwing 3.1.0 RC and found a button display problem. We are using borderless buttons to build a menu by our own (we could convince our customer to use the built-in menus from Swing/AjaxSwing). Since 3.1.0 the buttons are displayed with a thin border line eventhow they should have any. See the attached screenshots from the application run on AjaxSwing 3.0.0 final and AjaxSwing 3.1.0 RC.

Regards,
Jan

12
OK - if there is a fix available in the next release within a few days, I will rather wait for that :-)

Thanks for your help,
Jan
 

13
We have a GUI update problem which can be reproduced with the attached little application. the appications contains a JFrame with a text field and a button which clears the text field's content. When I type something into the text field and press the button afterwards, the text field is not cleared. If I force a repaint between filling the field and pressing the button (e.g. by resizing the frame), the field is properly cleared.

The problem only occurs in AjaxSwing - it all works fine under Swing. Tested with AjaxSwing 3.0.0, 3.0.1 and 3.0.5.

This topic is a copy of http://creamtec.com/forums/index.php?topic=421.0 in the community support forum

14
Hello AjaxSwing team
We have a commercial licence of AjaxSwing and I'd like to post support questions in the forum for commercial users. But there is no "NEW TOPIC" button to post a message. Do I have to use a certain dedicated user to access this forum?

Regards,
Jan Lessner

15
We have a GUI update problem which can be reproduced with the attached little application. the appications contains a JFrame with a text field and a button which clears the text field's content. When I type something into the text field and press the button afterwards, the text field is not cleared. If I force a repaint between filling the field and pressing the button (e.g. by resizing the frame), the field is properly cleared.

The problem only occurs in AjaxSwing - it all works fine under Swing. Tested with AjaxSwing 3.0.0, 3.0.1 and 3.0.5.

Pages: [1] 2 3 4